1

Тема: Сервер работает, а станция в листе не появляется...

Буду горячо благодарен за помощь:
Скачал с сайта всё что нужно. Установил.
Сделал настройки. Получил стат ip. Запускаю. Трафик пошёл.
Захожу на сайт Шоут, и пытаюсь найти себя в списке станций. Нету!
Делаю ещё несколько раз (как рекомендуют в хелпе) - опять нету.
И получить аутхаш теперь не получится. Просмотрел почти весь форум - похоже, я один такой тупой .... smile Ребята, череп кипит, когда не могу понять причину. Спасайте.

2

Re: Сервер работает, а станция в листе не появляется...

лог сервера смотри
99% случаев закрытый порт, или файрволл или NAT (роутер)

3

Re: Сервер работает, а станция в листе не появляется...

2012-01-26 18:21:27     I       msg:<***>       Logger startup
2012-01-26 18:21:27     I       msg:<***>       version 2.0.0.29
2012-01-26 18:21:27     D       msg:<***>
2012-01-26 18:21:27     I       msg:********************************************
*******************
2012-01-26 18:21:27     I       msg:** SHOUTcast Distributed Network Audio Serve
r (DNAS)
2012-01-26 18:21:27     I       msg:** Copyright (C) 1999-2011 Nullsoft, Inc.  A
ll Rights Reserved.
2012-01-26 18:21:27     I       msg:** Use "sc_serv filename.conf" to specify a
config file.
2012-01-26 18:21:27     I       msg:********************************************
*******************
2012-01-26 18:21:27     I       msg:[SHOUTcast] DNAS/win32 v2.0.0.29 (Jul 31 201
1) starting up...
2012-01-26 18:21:27     I       msg:[MAIN] PID: 3720
2012-01-26 18:21:27     I       msg:
2012-01-26 18:21:27     I       msg:[CONFIG] Choose one of the detected config f
ile(s) to load or
2012-01-26 18:21:27     I       msg:[CONFIG] enter `x' to close this instance of
the DNAS:
2012-01-26 18:21:27     I       msg:[CONFIG] Note: Press `Enter' after choosing
the config file.
2012-01-26 18:21:27     I       msg:[CONFIG]       Only the first 10 config file
s detected will be shown.
2012-01-26 18:21:27     I       msg:
2012-01-26 18:21:27     I       msg:[CONFIG]  [0]  :  sc_serv_basic.conf
2012-01-26 18:21:27     I       msg:[CONFIG]  [1]  :  sc_serv_debug.conf
2012-01-26 18:21:27     I       msg:[CONFIG]  [2]  :  sc_serv_public.conf
2012-01-26 18:21:27     I       msg:[CONFIG]  [3]  :  sc_serv_relay.conf
2012-01-26 18:21:27     I       msg:[CONFIG]  [4]  :  sc_serv_simple.conf
2012-01-26 18:21:27     I       msg:[CONFIG]  [5]  :  sc_trans_basic.conf
2012-01-26 18:21:27     I       msg:[CONFIG]  [6]  :  sc_trans_capture.conf
2012-01-26 18:21:27     I       msg:[CONFIG]  [7]  :  sc_trans_debug.conf
2012-01-26 18:21:27     I       msg:[CONFIG]  [8]  :  sc_trans_dj.conf
2012-01-26 18:21:27     I       msg:[CONFIG]  [9]  :  sc_trans_playlist.conf
2012-01-26 18:21:27     I       msg:
4
2012-01-26 18:21:31     I       msg:[MAIN] Logger updating log file to use
2012-01-26 18:21:31     I       msg:[MAIN] Loaded config from sc_serv_simple.con
f
2012-01-26 18:21:31     I       msg:[MAIN] Calculated CPU count is 1
2012-01-26 18:21:31     I       msg:[MAIN] Starting 1 network threads
2012-01-26 18:21:31     I       msg:[MICROSERVER] Listening for connection on po
rt 8000
2012-01-26 18:21:31     I       msg:[MICROSERVER] Listening for connection on po
rt 8001
2012-01-26 18:22:04     I       msg:[SRC 127.0.0.1:1277] SHOUTcast 2 source conn
ection.
2012-01-26 18:22:05     I       msg:[SRC 127.0.0.1:1277] Password accepted. Stre
am id is 1
2012-01-26 18:22:05     E       msg:[YP2] No authhash found for stream config #1
. Aborting registering stream with YP.
2012-01-26 18:22:05     I       msg:[SRC 127.0.0.1:1277 sid=1] stream configurat
ion complete. [

4

Re: Сервер работает, а станция в листе не появляется...

Вот, что лог сервера фиксирует. Если я правильно понимаю, отстутсвие аут-хаша прерывает регистрацию. Но тогда не понимаю, почему. Пишут, что сначала сервер регистрирует и отображает новый поток, потом я захожу на адинскую страничку и получаю аут-хаш. Что то я не въеду никак. Столько информации на их сайте, куча всяких инструкций по настройке,  а элементарной понятной пошаговой инструкции , для простых и наивных, нет.
Или я такой тупой блин? smile
Помогите разобраться, плиз, или подскажите, где есть понятная информация на русском, а ещё лучше - понятные инструменты для создания радио канала.

5

Re: Сервер работает, а станция в листе не появляется...

No authhash found for stream config #1
. Aborting registering stream with YP.

надо вначале зарегистрироваться на сайте shoutcast.com тогда дадут хеш и покажут куда и как его вставить

6

Re: Сервер работает, а станция в листе не появляется...

интересен такой вопрос...что должно быть установлено на виндовссервер 2003 что бы корректно работала программа радиобосс или сэм?..просто после установки не одна из них не хочет отправлять музыку...радиобосс постояно выдает какие то ошибки..сем вроде музыку в дэке воспроизводит но бегунок стоит на месте...вроде идет энкодиг на сервер айса нормально, но в айсе потока не появляется...и так к слову на сервере установлен первичный звуковой драйвер http://img.janowcity.by/upload_image/83ca4464b937a7afc4f54f158c4c68ac.jpg

Отредактировано FortNoxBY (27-01-2012 15:42:58)

Пишу в спешке. Могут быть очепятки
Сайт за 50$. За 2 дня...

7

Re: Сервер работает, а станция в листе не появляется...

что должно быть установлено на виндовссервер 2003

Linux lol

8

Re: Сервер работает, а станция в листе не появляется...

ну да...вопрос наверно смешной...но важный...блин оплатил 2 сервера на виндовс и линукс для теста...и хоть бы на одном все нормально было...на компе все гуд а сервере херня какаето((

Пишу в спешке. Могут быть очепятки
Сайт за 50$. За 2 дня...

9

Re: Сервер работает, а станция в листе не появляется...

радиобосс постояно выдает какие то ошибки..

учимся читать, понимать и исправлять эти ошибки

10

Re: Сервер работает, а станция в листе не появляется...

Вот все глаза проглядел! Не вижу я, где там предлагают зарегистрировваться, и получить аутхаш....  Ну что за ф-ня такая?

11

Re: Сервер работает, а станция в листе не появляется...

может нужны плагины или какие либо кодеки в моем случае с виндовс сервером 2003

Пишу в спешке. Могут быть очепятки
Сайт за 50$. За 2 дня...

12

Re: Сервер работает, а станция в листе не появляется...

http://wiki.winamp.com/wiki/SHOUTcast_A … t#Creating

щас видимо это делаеться в админке сервера

13

Re: Сервер работает, а станция в листе не появляется...

Спасибо за поддержку и внимание. Твои слова - "учимся читать, понимать и исправлять" - помогли в том числе. 1000 благодарностей. Жму руку. smile

Для тех, кто будет искать ответы на те же вопросы: по ссылке - http://wiki.winamp.com/wiki/SHOUTcast_A … t#Creating    - идём на страничку, там ещё одна ссылка - //127.0.0.1:8000/admin.cgi - по ней откроется окно, где нужно ввести логин admin, а пароль тот, что записали в файлах настройки сервера **.conf, при этом винамп и сервер должны быть запущены. Откроется страница  "SHOUTcast DNAS Administrator Summary" - на ней сгенерируется authhash, который нужно будет ввести в те же файлы **.conf

14

Re: Сервер работает, а станция в листе не появляется...

пишет FortNoxBY:

может нужны плагины или какие либо кодеки в моем случае с виндовс сервером 2003

Сталкивался когда-то с подобной проблемкой, арендуя для теста винду 2003 вдс.
Решением было, установка радмин сервера на виндовом сервере вдс, и подключение только через него (не через стандартный виндовый rdp)
Далее установка и запуск аудио-службы на сервере. Ещё какие-то мелочи в настройках политики для пользователей вроде делал.
Ну и после чего, радиобосс таки работал. Главное, чтобы был звук, не подключаться через стандартное Удалённое подключение к рабочему столу. Остальное уже запуск службы аудио и т.д - это уже мелочи.

Radiodev - coming soon.

15

Re: Сервер работает, а станция в листе не появляется...

вот собствено что у меня сейчас имеется
http://img.janowcity.by/upload_image/0a78fe2835853a5a07ff94dec68dbf3d.jpg

http://img.janowcity.by/upload_image/86381f290e877bafb4eb6899408237b7.jpg

http://img.janowcity.by/upload_image/f37e08d94110c7d40b89a9cdd5d808a6.JPG

Пишу в спешке. Могут быть очепятки
Сайт за 50$. За 2 дня...

16

Re: Сервер работает, а станция в листе не появляется...

Рановато я радовался. Аутхаш не присваивается. Чего то опятьему не хватает. Блин, до чего геморройную штуку придумали эти ребята ...

17

Re: Сервер работает, а станция в листе не появляется...

Я раньше когда еще на сайте регистрировался давали хеш то вносил его в настройки и все было гуд.
Возможно в настройках еще пошуршать надо
Но я кстате до сих пор сижу на старом шоуткасте 1.9.8, там таких заморочек нет

18

Re: Сервер работает, а станция в листе не появляется...

Да вот и я прихожу к выводу, что тратить столько времени только на настройку, .... а потом же ещё похожий гимор будет с "фенечками, приблудами и прибамбасами" разными, чтобы сделать вещание привлекательным а обслуживание - удобным. Это уже черезчур.
Подскажи пожалуйста, есть мануалка на русском для сервера последнего релиза?
Может посоветуешь, какие альтернативные варианты можно приментить для создания интернет-радио? Или просто взять Шоуткаст 1.9.8. и не париться? Я видел, если не ошибся, что ты уже выкладывал конфиги для него.

19

Re: Сервер работает, а станция в листе не появляется...

Да только вопрос опять может в этот аутхеш упереться. Даже на предыдущей версии шоуткаста .... Не могу пока разобраться, почему аутхеш не дают. Пишут нужно изменить настройки браузера для обеспечения доступа. Я вырубил антивирусник вообще, внёс сайт в доверенные ...  и ничего не изменилось ...

20

Re: Сервер работает, а станция в листе не появляется...

мануалов к последнему на русском нет

предыдущая версия это какая имеетья ввиду?

21

Re: Сервер работает, а станция в листе не появляется...

Я имел в виду ту версию, о которой писал ты, и которая работает без проблем.

22

Re: Сервер работает, а станция в листе не появляется...

в той версии хеш не нужен

23

Re: Сервер работает, а станция в листе не появляется...

Тогда подскажи пожалуйста, где можно качнуть эту версию и рабочий лог к ней? Есть у тебя ссылка?

24

Re: Сервер работает, а станция в листе не появляется...

http://www.shoutcast2.de/shoutcast-server-version-198/ но только на линукс, для виндовс - гугл в помощь

пс не лог а конфиг

25

Re: Сервер работает, а станция в листе не появляется...

Сорри, конечно конфиг.
Спасибо, в гугле наверняка что то есть. smile