1

Тема: Проблема с mount на icecast2

Добрый день!
Поставил icecast2. Платформа UBUNTU.
настроил на нем relay с другого канала и mount.
Так вот если на mount не подавать поток (пробовал ices2 и liquidsoap), то icecast нормально релеет с чужого ресурса. Как только запускаю стриммер на своей машине и пытаюсь запустить поток в плеере на другом компе (winamp) происходит следующее: Плеер вроде бы как коннектится но дальше http1.0 200Ok не идет. Хотя на странице myhost:8000 висит информация о потоке и обновляется корректно, что говорит о том, что поток со стриммера доходит до icecast.

Вот конфиг.

Показать / Cкрыть текст

И кусок лога.

Показать / Cкрыть текст


Помогите пожалуйста.

2

Re: Проблема с mount на icecast2

может банально нет кодека? можно ссылку?

3

Re: Проблема с mount на icecast2

пишет tarasian666:

может банально нет кодека? можно ссылку?

По кодекам не знаю..
Ссылка
http://lostzone.ath.cx:8000/listen - релей
http://lostzone.ath.cx:8000/lost - маунт (сейчас вроде как liquidsoap работает)

4

Re: Проблема с mount на icecast2

я опоздал, сейчас ничего не работает ))

5

Re: Проблема с mount на icecast2

пишет tarasian666:

я опоздал, сейчас ничего не работает ))

Можно сейчас посмотреть.. сервер запущен. Два потока /listen - релей
и /lost - ices2 (плейлист)

6

Re: Проблема с mount на icecast2

все работает

7

Re: Проблема с mount на icecast2

пишет tarasian666:

все работает

Работает, но не так как надо. Сейчас на /lost играет релей.. так как он указан в качестве fallback-mount у потока /lost
Ситуация такая. запускаю icecast и ices. По идее на /listen должен играть релей а на /lost - данные, передаваемые ices. После запуска /lost висит некоторое время (в плеере дальше HTTP/1.0 200Ok ничего не идет) после чего этот поток падает и /lost автоматом переключается на /listen (на котором играет релей).

Не могу понять в чем проблема. Почему маунт на котором играет ices не работает в плеере?

В плейлисте в пути к звуковым файлам есть русские символы (home/<user>/Музыка/1.ogg и т.д.)

Отредактировано ArmiT (09-07-2010 10:04:50)

8

Re: Проблема с mount на icecast2

кстате, на странице icecast не видно маунта с ices а с конфига видно что он не hidden значит поток не идет с ices

Добавлено спустя     2 минуты   47 секунд:
а вот сейчас видно и все работает но у вас несовпадение форматов потому так получается

Отредактировано tarasian666 (09-07-2010 10:13:27)

9

Re: Проблема с mount на icecast2

пишет tarasian666:

а вот сейчас видно и все работает но у вас несовпадение форматов потому так получается

В смысле, несовпадение форматов. Все файлы вроде как ogg формата.

10

Re: Проблема с mount на icecast2

поток и fallback должны быть в одном формате

11

Re: Проблема с mount на icecast2

пишет tarasian666:

поток и fallback должны быть в одном формате

Посмотрел.заменил fallback-mount на /home/<user>/Музыка/error.ogg. Файл 96000 44100 как и на стройки самого потока в ices2

Вот конфиг ices2

Показать / Cкрыть текст

12

Re: Проблема с mount на icecast2

я говорю о том, что релей в mp3, а ices в ogg при пропадании одного плавного перехода на другой не будет, надо будет останавлявать и наново запускать плеер

13

Re: Проблема с mount на icecast2

пишет tarasian666:

я говорю о том, что релей в mp3, а ices в ogg при пропадании одного плавного перехода на другой не будет, надо будет останавлявать и наново запускать плеер

Отключил релей. Оставил только mount /lost (тот, что играет ices2). Не помогло ситуация та же.

14

Re: Проблема с mount на icecast2

у меня играет, значит у вас проблема с кодеками

15

Re: Проблема с mount на icecast2

пишет tarasian666:

у меня играет, значит у вас проблема с кодеками

Т.е. у меня на моей виндовой машине (Windows 7) на винампе нет кодеков?
Просто странно, что на странице http://lostzone.ath.cx:8000/ в секции Current Song: постоянно пусто.

16

Re: Проблема с mount на icecast2

пишет ArmiT:

Т.е. у меня на моей виндовой машине (Windows 7) на винампе нет кодеков?

да

пишет ArmiT:

Просто странно, что на странице http://lostzone.ath.cx:8000/ в секции Current Song: постоянно пусто.

возможно при сборке ices небыл включен какой то модуль, например в ices0.4 без perl не показывает титлов

17

Re: Проблема с mount на icecast2

пишет tarasian666:

пишет ArmiT:

Т.е. у меня на моей виндовой машине (Windows 7) на винампе нет кодеков?

да

пишет ArmiT:

Просто странно, что на странице http://lostzone.ath.cx:8000/ в секции Current Song: постоянно пусто.

возможно при сборке ices небыл включен какой то модуль, например в ices0.4 без perl не показывает титлов

Видимо, дело не в кодеках. Поставил klite codec pack. В винампе локальные ogg файлы играет а поток не воспроизводит. Не пойму в чем дело. Он действительно играет (маунт)?

Поставил AIMP, блин заработало. Странно, почему Winamp не пашет.

Отредактировано ArmiT (09-07-2010 11:32:54)

18

Re: Проблема с mount на icecast2

винам локально может и воспринимает но поток не хочет. Так что лучше (для масс) транслируйте в mp3

19

Re: Проблема с mount на icecast2

пишет tarasian666:

винам локально может и воспринимает но поток не хочет. Так что лучше (для масс) транслируйте в mp3

А для mp3 какой стриммер лучше было бы?

20

Re: Проблема с mount на icecast2

ices0.4
sc_trans2
liquidsoap (svn)

лично я за liquidsoap

21

Re: Проблема с mount на icecast2

пишет tarasian666:

ices0.4
sc_trans2
liquidsoap (svn)

лично я за liquidsoap

Спасибо за помощь!)))